use strict;
my $str = 'https://www.tokopedia.com/laris88/tempat-bumbu-dapur-4-sekat-joyfeel-1047-seasoning-storage-merah-muda
https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali?whid=0
https://www.tokopedia.com/tenonenonet/gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali
https://gql.tokopedia.com/tokopedia.com/
https://gql.tokopedia.com/ceriasmart/
https://gql.tokopedia.com/22ceria.-smart/
tokopedia\\.com/([^/]+[\\w])
todo
i want grab only "gift-box-kotak-kado-souvenir-hadiah-ukuran-14-x-14-x-5cm-plus-tali" without end character \'?\'
tokopedia\\.com/[^/]*[\\w\\/](.*)|[?!\\?]';
my $regex = qr/(?<=\/)[\w\-.]+(?=(\?|(\s*)$|(\/)$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}