using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Header[^:]+:([\s\S]*?)(?=Header|$)";
string input = @"Header One: Some random text Header Two: Some more text Header One: Some random textwerwerwefvxcf234234 Header Three: Some more t2345fsdfext Header Four: Some randsdfsdf3w42343om text Header Five: Some more text 123213";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}