re = /Header[^:]+:([\s\S]*?)(?=Header|$)/
str = 'Header One: Some random text Header Two: Some more text Header One: Some random textwerwerwefvxcf234234 Header Three: Some more t2345fsdfext Header Four: Some randsdfsdf3w42343om text Header Five: Some more text 123213'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end