const regex = /^https?:\/\/(?!localhost)[\.\w\d]{2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/(?!localhost)[\\.\\w\\d]{2,}', 'gm')
const str = `teste
http://www.outro.com.br
http://localhost
https://net.sec.org?outra=query
https://api.outro.com/?q
http://www.unsecuredapi.com
http//www
https:/www.com.br
https://regex101.com/
https://bin.com.br
http://bin.com
://teste
wss://outro
htt://mais.um.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}