import re
regex = re.compile(r"^https?:\/\/(?!localhost)[\.\w\d]{2,}", flags=re.MULTILINE)
test_str = ("teste\n"
"http://www.outro.com.br\n"
"http://localhost\n"
"https://net.sec.org?outra=query\n"
"https://api.outro.com/?q\n"
"http://www.unsecuredapi.com\n"
"http//www\n"
"https:/www.com.br\n"
"https://regex101.com/\n"
"https://bin.com.br\n"
"http://bin.com\n"
"://teste\n"
"wss://outro\n"
"htt://mais.um.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")