# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\.\w+\s*\(\w+)2/\g<1>1/gm;t' <<< ".B (b2),"