const regex = new RegExp('(\\.\\w+\\s*\\(\\w+)2', 'gm')
const str = `.B (b2),`;
const subst = `\g<1>1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);