use strict;
my $str = 'Allowed:
12
2
32132
123212
1321312312
1232123212321
32321232123232323213
21313131313131212312321231
Not Allowed:
11
22
33
113
1223
321233
13233232
23123232122';
my $regex = qr/^((1(23)*23?|1(32)*32?)*1?|(2(13)*13?|2(31)*31?)*2?|(3(21)*21?|3(12)*12?)*3?)$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}