$re = '/^((1(23)*23?|1(32)*32?)*1?|(2(13)*13?|2(31)*31?)*2?|(3(21)*21?|3(12)*12?)*3?)$/mx';
$str = 'Allowed:
12
2
32132
123212
1321312312
1232123212321
32321232123232323213
21313131313131212312321231
Not Allowed:
11
22
33
113
1223
321233
13233232
23123232122';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);