const regex = /(?<=found: \d+)\n[\n|\W|\w]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=found: \\d+)\\n[\\n|\\W|\\w]*', 'gm')
const str = `Number of results that have been found: 1234
result1
result2
result3
result4
...
...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}