$re = '/(?<=found: \d+)\n[\n|\W|\w]*/m';
$str = 'Number of results that have been found: 1234
result1
result2
result3
result4
...
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);