package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?:X.*Y)|(?:Y.*X))(.*)(?:Z)`)
var str = `The only X thing Z that X should Y match Z is match.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}