re = /(?:(?:X.*Y)|(?:Y.*X))(.*)(?:Z)/
str = 'The only X thing Z that X should Y match Z is match.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end