import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:todo|fixme):?\\s*(?:\\w+\\-\\d+|https\\S*)";
final String string = "TODO: AS-123 no match\n"
+ "todo: as-123 no match\n"
+ "fixme: https://jira.company.com/browse/AS-14965 no match\n"
+ "fixme: https://jira.company.com\n"
+ "fixme as-123 no match\n"
+ "todo:as-123 no match\n\n\n"
+ "todo match\n"
+ "todo match\n"
+ "todo:match\n"
+ "todo :match\n"
+ "todo123\n"
+ "todo : match\n"
+ "todo: match\n"
+ "fixme: match\n"
+ "todo: match https://jira.company.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}