re = /(?:todo|fixme):?\s*(?:\w+\-\d+|https\S*)/mi
str = 'TODO: AS-123 no match
todo: as-123 no match
fixme: https://jira.company.com/browse/AS-14965 no match
fixme: https://jira.company.com
fixme as-123 no match
todo:as-123 no match
todo match
todo match
todo:match
todo :match
todo123
todo : match
todo: match
fixme: match
todo: match https://jira.company.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end