const regex = /(?:todo|fixme)\s*:?\s*(?!http\S*)(?!.*\w+\-\d+).*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:todo|fixme)\\s*:?\\s*(?!http\\S*)(?!.*\\w+\\-\\d+).*$', 'gmi')
const str = `TODO: AS-123 no match
todo: as-123 no match
fixme: https://jira.company.com/browse/AS-14965 no match
fixme: https://jira.company.com
fixme as-123 no match
todo:as-123 no match
todo match
todo match
todo:match
todo :match
todo123
todo : match
todo: match
fixme: match
todo: match https://jira.company.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}