import re
regex = re.compile(r"(?:todo|fixme)\s*:?\s*(?!http\S*)(?!.*\w+\-\d+).*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("TODO: AS-123 no match\n"
"todo: as-123 no match\n"
"fixme: https://jira.company.com/browse/AS-14965 no match\n"
"fixme: https://jira.company.com\n"
"fixme as-123 no match\n"
"todo:as-123 no match\n\n\n"
"todo match\n"
"todo match\n"
"todo:match\n"
"todo :match\n"
"todo123\n"
"todo : match\n"
"todo: match\n"
"fixme: match\n"
"todo: match https://jira.company.com/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")