# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*-> addField\(('\S*').*?, \['type' => new (\S*?)Type.*"
test_str = ("-> addField('id' , ['type' => new IntType , 'description' => __('id')])\n"
" -> addField('type_mandaat' , ['type' => new StringType , 'description' => __('type mandaat')])\n"
" -> addField('bedrag' , ['type' => new BedragType , 'description' => __('bedrag')])\n"
" -> addField('datum_expertise_plaatsgevonden' , ['type' => new DateType , 'description' => __('datum van expertise')])\n"
" -> addField('datum_ontvangst_rapport' , ['type' => new DateType , 'description' => __('datum van ontvangst rapport')])\n"
" -> addField('omschrijving' , ['type' => new StringType , 'description' => __('omschrijving')])\n"
" -> addField('wrakwaarde' , ['type' => new BedragType , 'description' => __('wrakwaarde')])\n"
" -> addField('forfait' , ['type' => new BooleanType , 'description' => __('forfait')])\n"
" -> addField('total_loss' , ['type' => new BooleanType , 'description' => __('total loss')])\n"
" -> addField('kosten_expertise' , ['type' => new FloatType , 'description' => __('kosten expertise')])\n"
" -> addField('experts' , ['type' => new ListType(new ExpertInput), 'description' => __('experts')]);")
subst = "\\1 => ['type' => '\\2'],"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.