re = /.*-> addField\(('\S*').*?, \['type' => new (\S*?)Type.*/
str = '-> addField(\'id\' , [\'type\' => new IntType , \'description\' => __(\'id\')])
-> addField(\'type_mandaat\' , [\'type\' => new StringType , \'description\' => __(\'type mandaat\')])
-> addField(\'bedrag\' , [\'type\' => new BedragType , \'description\' => __(\'bedrag\')])
-> addField(\'datum_expertise_plaatsgevonden\' , [\'type\' => new DateType , \'description\' => __(\'datum van expertise\')])
-> addField(\'datum_ontvangst_rapport\' , [\'type\' => new DateType , \'description\' => __(\'datum van ontvangst rapport\')])
-> addField(\'omschrijving\' , [\'type\' => new StringType , \'description\' => __(\'omschrijving\')])
-> addField(\'wrakwaarde\' , [\'type\' => new BedragType , \'description\' => __(\'wrakwaarde\')])
-> addField(\'forfait\' , [\'type\' => new BooleanType , \'description\' => __(\'forfait\')])
-> addField(\'total_loss\' , [\'type\' => new BooleanType , \'description\' => __(\'total loss\')])
-> addField(\'kosten_expertise\' , [\'type\' => new FloatType , \'description\' => __(\'kosten expertise\')])
-> addField(\'experts\' , [\'type\' => new ListType(new ExpertInput), \'description\' => __(\'experts\')]);'
subst = '\\1 => [\'type\' => \'\\2\'],'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result