$re = '/(?!\.\w)(?![\'\/#$])\p{P}/m';
$str = '.net, asp.net hello. world, c#
.net asp.net hello world c#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);