re = /(?!\.\w)(?!['\/#$])\p{P}/m
str = '.net, asp.net hello. world, c#
.net asp.net hello world c#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end