#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)https:\/\/www\.bugaboo\.com\/.{2}-.{2}\/(onderdelen|pieces|parts|recambios).*\.html"
Local $sString = "https://www.bugaboo.com/be-en/parts/bugaboo-cameleon-6inch-front-swivel-wheel-foam-780531.html" & @CRLF & _
"" & @CRLF & _
"https://www.bugaboo.com/es-en/parts/bugaboo-cameleon-6inch-front-swivel-wheel-foam-780531.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")