$re = '/https:\/\/www\.bugaboo\.com\/.{2}-.{2}\/(onderdelen|pieces|parts|recambios).*\.html/m';
$str = 'https://www.bugaboo.com/be-en/parts/bugaboo-cameleon-6inch-front-swivel-wheel-foam-780531.html
https://www.bugaboo.com/es-en/parts/bugaboo-cameleon-6inch-front-swivel-wheel-foam-780531.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);