const regex = /^\S+\h+(\S+)[^\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\S+\\h+(\\S+)[^\\n]+', 'gm')
const str = `Имя Фамилия Отчество`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);