import re
regex = re.compile(r"(?<=\(|AND )(?:(?:red:|blue:|green:)(*SKIP)(*FAIL)|[^:]+)")
test_str = ("(green:bar AND black:foo)\n"
"(blue:bar AND darkblue:foo)\n"
"(yellow:bar AND grey:foo)\n"
"(greengarden:bar AND red:foo)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")