$re = '/\bapple[!,?.\'\"]*(?=\s+|$)/m';
$str = 'apple apple@323 apple.. apple??...!! apple??%% Ilovesapple
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);