re = /\bapple[!,?.'\"]*(?=\s+|$)/m
str = 'apple apple@323 apple.. apple??...!! apple??%% Ilovesapple
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end