using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*:\s*";
string substitution = @":";
string input = @"Mr Moose : Maths
Mr Goose: History
Mrs Congenelipilling: English";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}