import re
regex = re.compile(r"\s*:\s*")
test_str = ("Mr Moose : Maths\n"
"Mr Goose: History\n"
"Mrs Congenelipilling: English")
subst = ":"
result = regex.sub(subst, test_str)
if result:
print(result)