package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)payment no: (\d+)`)
var str = `Payment Instrument modified. payment no: 5000000000000000, method: C for transponder: 5000000000000000 transponder type: A
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}