# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/OPTIONS=\"(?:(.*)(-u [a-z]+:[a-z]+)?)(.*?)\"/OPTIONS="\1 \3 -u ntpd:ntpd"/gm;t' <<< "OPTIONS=\"-x -u wrong:wrong -c blah\"
OPTIONS=\"-u wrong:wrong -x -c blah\"
OPTIONS=\"-x -c blah -u wrong:wrong\"
OPTIONS=\"-x -c blah\""