#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)OPTIONS=\"(?:(.*)(-u [a-z]+:[a-z]+)?)(.*?)\""
Local $sString = "OPTIONS="-x -u wrong:wrong -c blah"" & @CRLF & _
"OPTIONS="-u wrong:wrong -x -c blah"" & @CRLF & _
"OPTIONS="-x -c blah -u wrong:wrong"" & @CRLF & _
"OPTIONS="-x -c blah""
Local $sSubst = "OPTIONS="\1 \3 -u ntpd:ntpd""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)