import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^==\\h*Upgrade Notice\\h*==(?:(?:\\R(?!=\\h*\\d+\\.\\d+\\.\\d+\\h*=$).*)*\\R=\\h*(\\d+\\.\\d+\\.\\d+)\\h*=$\\s*){2}(^\\h*\\S.*(?:\\R\\h*\\S.*)+)";
final String string = "Some stuff before this notice like a changelog with versioning and explanation text.\n\n"
+ "== Upgrade Notice ==\n\n"
+ "= 1.3.0 =\n\n"
+ "When using Master Pro, 1.3.0 is the new minimal required version!\n"
+ "This is a test\n\n"
+ "= 1.1.0 =\n\n"
+ "When using Master Pro, 1.1.0 is the new minimal required version!\n"
+ "this is\n"
+ "a test\n\n"
+ "= 1.0.0 =\n\n"
+ "No upgrade - just install :)\n"
+ "another thest\n\n"
+ "[See changelog for all versions](https://plugins.svn.wordpress.org/master-pro/trunk/CHANGELOG.md).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}