re = /^==\h*Upgrade Notice\h*==(?:(?:\R(?!=\h*\d+\.\d+\.\d+\h*=$).*)*\R=\h*(\d+\.\d+\.\d+)\h*=$\s*){2}(^\h*\S.*(?:\R\h*\S.*)+)/m
str = 'Some stuff before this notice like a changelog with versioning and explanation text.
== Upgrade Notice ==
= 1.3.0 =
When using Master Pro, 1.3.0 is the new minimal required version!
This is a test
= 1.1.0 =
When using Master Pro, 1.1.0 is the new minimal required version!
this is
a test
= 1.0.0 =
No upgrade - just install :)
another thest
[See changelog for all versions](https://plugins.svn.wordpress.org/master-pro/trunk/CHANGELOG.md).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end