import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(TASK\\s*\\(.*?\\)\\s)(\\{((?>[^\\{\\}]+|(?2))*)\\})";
final String string = "TASK(arg1)\n"
+ "{\n"
+ " if (cond)\n"
+ " {\n"
+ " /* Comment */\n"
+ " function_call();\n"
+ " if(condIsTrue)\n"
+ " {\n"
+ " DoSomethingelse();\n"
+ " }\n"
+ " }\n"
+ " if (cond1)\n"
+ " {\n"
+ " /* Comment */\n"
+ " function_call1();\n"
+ " }\n"
+ "}\n\n"
+ "void FunctionIDoNotWant(void)\n"
+ "{\n"
+ " if (cond)\n"
+ " {\n"
+ " /* Comment */\n"
+ " function_call();\n"
+ " }\n"
+ " if (cond1)\n"
+ " {\n"
+ " /* Comment */\n"
+ " function_call1();\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}