$re = '/(TASK\s*\(.*?\)\s)({((?>[^{}]+|(?2))*)})/m';
$str = 'TASK(arg1)
{
if (cond)
{
/* Comment */
function_call();
if(condIsTrue)
{
DoSomethingelse();
}
}
if (cond1)
{
/* Comment */
function_call1();
}
}
void FunctionIDoNotWant(void)
{
if (cond)
{
/* Comment */
function_call();
}
if (cond1)
{
/* Comment */
function_call1();
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);