package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^01[3-9]\d{8}$`)
var str = `01872339806`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}