$re = '/^01[3-9]\d{8}$/m';
$str = '01872339806';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);