re = /^[A-Z][a-z ,.'-]+(?: [A-Z][a-z ,.'-]+)*$/m
str = 'Jane Doe
Foo Bar
bar bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end