package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^\u0000-\u007F]|[\|`])+`)
var str = `😊\`
not a match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}