$re = '/(?:[^\u0000-\u007F]|[\|`])+/m';
$str = '😊`
not a match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);