$re = '/\b(?<![Yy]ellow )(?<![Bb]lue )(?<![Rr]ed )(?<![Pp]urple )(?<![Bb]lack )[Cc]olor/m';
$str = 'Dark Color #match
light color #match
Blue Color
red color
that is a blue color and theme
opaque color #match
purple color';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);