re = /\b(?<![Yy]ellow )(?<![Bb]lue )(?<![Rr]ed )(?<![Pp]urple )(?<![Bb]lack )[Cc]olor/m
str = 'Dark Color #match
light color #match
Blue Color
red color
that is a blue color and theme
opaque color #match
purple color'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end