import re
regex = re.compile((r"(?x) # free-spacing mode\n"
r"(?(DEFINE) \n"
r" # decimal to decimal: 1.2% to 21.53%\n"
r" (?<dec_to_dec>\n"
r" (?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])\n"
r" ) \n"
r" # Decimal to Whole number: 1.2% to 21%\n"
r" (?<dec_to_int>\n"
r" (?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])\n"
r" )\n"
r" # Whole number to Decimal: 1% to 21.53%\n"
r" (?<int_to_dec>\n"
r" (?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\,\.][0-9]{1,3}[\%])\n"
r" )\n"
r" # Whole number to whole number: 1% to 21%\n"
r" (?<int_to_int>\n"
r" (?:[0-9]{1,3}[\%]\sto\s[0-9]{1,3}[\%])\n"
r" ) \n"
r" # Single Whole Number: 21%\n"
r" (?<single_int>\n"
r" (?:[0-9]{1,3}[\%])\n"
r" )\n"
r" # Single Whole Number: 21%\n"
r" (?<single_dec>\n"
r" (?:[0-9]{1,3}[\,\.][0-9]{1,3}[\%])\n"
r" )\n"
r")\n"
r"(?&dec_to_dec)|(?&dec_to_int)|(?&int_to_dec)|(?&int_to_int)|(?&single_int)|(?&single_dec)"), flags=re.MULTILINE)
test_str = "France: 2.8% to 21%"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")