using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class='pages'>(.*?)</span>";
string input = @"<span class='pages'>1 de <!-- <span> comentado </span> --> 8</span><span class='current'>1</span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}