package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span class='pages'>(.*?)</span>`)
var str = `<span class='pages'>1 de <!-- <span> comentado </span> --> 8</span><span class='current'>1</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}