$re = '%<span class=\'pages\'>((?:[^<>]*|(?=<!--).*?-->)*)</span>%m';
$str = '<span class=\'pages\'>1 de <!-- <span> comentado </span> --> 8</span><span class=\'current\'>1</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);