re = /<span class='pages'>((?:[^<>]*|(?=<!--).*?-->)*)<\/span>/m
str = '<span class=\'pages\'>1 de <!-- <span> comentado </span> --> 8</span><span class=\'current\'>1</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end