package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)_(.*?)_.*?_(.*)$`)
var str = `111352_01_2_SAMPLE_TEXT_SAMPLE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}