$re = '/^(.*?)_(.*?)_.*?_(.*)$/m';
$str = '111352_01_2_SAMPLE_TEXT_SAMPLE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);